Workaround for vulnerability affecting Internet Explorer

by Andy on November 4th, 2010 in Security Alert, Security Tips.

Microsoft has released a security advisory concerning a vulnerability affecting Internet Explorer versions 6, 7 and 8. This vulnerability may allow an attacker to execute arbitrary code. Full details here.


Visit Microsoft's page here to get full instructions. You can find the workarounds under the "Suggested Actions" twisty.


The workarounds include overriding the Web site CSS with a user-defined style sheet, deploying the Enhanced Mitigation Experience Toolkit, enabling Data Execution Prevention (DEP) for Internet Explorer 7 and setting Internet and Local intranet security zone settings to "High" to block ActiveX Controls and Active Scripting in these zones.